Составьте программу,которая формирует массив из 15 случайных целых цифр от -20 до 20 и меняет местами значения первого и последнего элементов массива.на экран выводятся исходные и преобразованные значения.надо

alexalu0402 alexalu0402    3   01.03.2019 09:40    10

Ответы
Аліна02012003 Аліна02012003  23.05.2020 18:06

program xxx;

    var i : integer;

         a : array[1..15] of real; 
         n : real; 
begin 
  randomize; 
  for i:=1 to 15 do 
    a[i]:=random(20)-20; 

   writeln('исходный массив А:');

   for i:=1 to 15 do

      write(a[i]);

   n:=a[1];

   a[1]:=a[15];

   a[15]:=n;

   writeln('полученный массив А:');

   for i:=1 to 15 do

      write(a[i]);

   readln

end.

  

ПОКАЗАТЬ ОТВЕТЫ
Valida12 Valida12  23.05.2020 18:06
var m:array[1..15] of real; 
i:integer; 
n:real; 
begin 
randomize; 
for i:=1 to 15 do 
begin 
m:=random(20)-20; 
if( m<0) then 
begin 
m:=sqr(m); 
end;
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика