Составьте программу, которая для числа k (от 1 до 99), введенного вами, напечатает фразу «мне k лет», где k – введенное число, при этом в нужных случаях слово «лет» заменяя на «год» или «года». например, при k=70 «мне 70 лет», при k=15 «мне 15 лет», при k=23 «мне 23 года», при k=31 «мне 31 год». что значит until и case в этой

nikitkaandreev1 nikitkaandreev1    2   07.06.2019 03:50    25

Ответы
ученик1523 ученик1523  01.10.2020 21:11
Программа на Pascal
 var   Age : integer;
begin Repeat Write('Введите Ваш возраст: ');
Readln(Age); until Age in [1..99];
if Age in [10..20] then Writeln('Мне ', Age, ' лет')
else    case Age mod 10 of    1: Writeln('Мне ', Age, ' год');    
2, 3, 4 : Writeln('Мне ', Age, ' года');    
0, 5..9 : Writeln('Мне ', Age, ' лет');
end;
end.
программа на C++
#include <iostream> 
using namespace std; 
int main() 
{ 
setlocale(LC_ALL,"rus"); 
int k; 
cin>>k; 
if(k >0 && k<100) 
cout<<"Мне "<< k <<" лет"; 
system("pause >> void"); 
}
ПОКАЗАТЬ ОТВЕТЫ
dratyti20041605 dratyti20041605  01.10.2020 21:11
Var k:integer;
begin
     readln(k);
     case k of
          10..20: writeln('Мне ', k ,' лет');
     else
          case k mod 10 of
               1   : writeln('Мне ', k ,' год');
               2..4: writeln('Мне ', k ,' года');
          else writeln('Мне ', k ,' лет');
          end;
     end;
end.
//
#include <iostream>
using namespace std;
int main()
{
    int k;
    cin >> k;
    if (k >= 10 && k <= 20)
        cout << "Мне " << k << " лет" << endl;
    else
        switch (k % 10)
        {
            case 1: cout << "Мне " << k << " год" << endl; break;
            case 2: cout << "Мне " << k << " года" << endl; break;
            case 3: cout << "Мне " << k << " года" << endl; break;
            case 4: cout << "Мне " << k << " года" << endl; break;
            default: cout << "Мне " << k << " лет" << endl; break;
        }
}
//
case - оператор выбора
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика