Составьте программу, которая для целого числа k (от 1 до 99), введенного вами, напечатает фразу «Мне k лет», при этом в нужных случаях слово «лет» заменяя на слово «год» или «года».

На языке Паскаль
С использованием оператора switch, case

timurgu08 timurgu08    2   03.06.2020 00:01    5

Ответы
anutik4 anutik4  06.08.2020 15:53

var

Age : integer;

begin

Repeat

Write('Введите Ваш возраст: ');

Readln(Age);

until Age in [1..99];

if Age in [10..20] then Writeln('Мне ', Age, ' лет') else

case Age mod 10 of

1: Writeln('Мне ', Age, ' год');

2, 3, 4 : Writeln('Мне ', Age, ' года');

0, 5..9 : Writeln('Мне ', Age, ' лет');

end;

end.

ПОКАЗАТЬ ОТВЕТЫ
alenalavkav7 alenalavkav7  06.08.2020 15:53

// PascalABC.NET

begin

 var n := ReadInteger('Введите возраст (1-99):');

 if not (n in 1..99) then

   Print('Неверный возраст')

 else if n in 10..20 then

   Print('Мне', n, 'лет')

 else

   case n mod 10 of

     1: Print('Мне', n, 'год');

     2..4: Print('Мне', n, 'года');

   else Print('Мне', n, 'лет')

   end;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика