Составьте программу, которая будет определять положительное или отрицательное число ( программа c++) заранее )

varvara083017 varvara083017    1   23.09.2019 17:30    4

Ответы
Pussyellien Pussyellien  08.10.2020 12:53
#include<iostream>
using namespace std;
int x;
int main(){
cin>>x;
if(x>0) cout<<"Polozhitelnoye'';
else cout<<"Otritsatelnoye'';
return 0;}

Составьте программу, которая будет определять положительное или отрицательное число ( программа c++)
ПОКАЗАТЬ ОТВЕТЫ
elenazarubina1 elenazarubina1  08.10.2020 12:53
Усложним задание:
#include <iostream>
#include <string>
using namespace std;

template<typename T>
string sign(const T& x)
{
    return x < 0 ? "negative" : x == 0 ? "0" : "positive";
}

int main()
{
    cout << sign(-3.14f);
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика