Составьте программу к следующей : ученик начал решать данного урока программирования, когда электронные часы показывали h1 часов и min1 минут, а закончил, когда было h2часов и min2 минут. составьте программу, позволяющую определить, сколько времени (в часах и минутах) ученик решал эти .

manovskidominik manovskidominik    3   24.08.2019 06:30    3

Ответы
vladt12092002 vladt12092002  05.10.2020 16:06
Используется время одних суток.
var h1,min1,h2,min2,h,min,m:integer;
begin
write('h1, m1: ');
readln(h1,min1);
write('h2, m2: ');
readln(h2,min2);
m:=(h2*60+min2)-(h1*60+min1);
h:=m div 60;
min:=m mod 60;
writeln('h = ',h,' min = ',min);
end.

Пример:
h1, m1: 1 20
h2, m2: 3 15
h = 1 min = 55
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика