Составьте программу. для вводимых с клавиатуры чисел определить количество положительных. ввод чисел прекращается, когда пользователь вводит 0.

ffbhhb ffbhhb    2   30.08.2019 07:10    3

Ответы
Ruslan123244 Ruslan123244  06.10.2020 04:36
Var a,k:integer;
begin
writeln('Вводите числа. Конец ввода - 0');
k:=0;
readln(a);
while a<>0 do
 begin
 if a>0 then k:=k+1;
 readln(a);
 end;
writeln('k = ',k);
end.

Пример:
Вводите числа. Конец ввода - 0
8
-4
5
-2
3
-7
0
k = 3
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика