tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составьте программу
Составьте программу для решения следующей : дан массив из 20 элементов, заполненныей случайными числами . найти минимальный элемент массива и его номера
dvinogradova20
3 02.09.2019 17:30
4
Ответы
Felua
03.08.2020 14:50
#include <iostream>
using namespace std;
int main()
{
setlocale(LC_ALL, "RUSSIAN");
const int arr_len=20;
int arr[arr_len];
int i = 0;
srand(8120);
for (i = 0; i < arr_len; i++)
{
arr[i] = rand() % 100;
cout << arr[i] << ' ';
}
cout << endl;
int min = 100, min_index=arr[0];
for (i = 0; i < arr_len; i++)
{
if (arr[i] < min)
{
min = arr[i];
min_index = i;
}
}
cout << "Минимальный элемент массива: " << min << endl;
cout << "Его индекс: " << min_index << endl;
system("pause");
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
12VikaSmirnova34
28.08.2019 19:50
Спрограммированием, . pascal 1. массив а (одномерный) задан случайным образом. найти сумму его элементов с четными номерами, произведение отрицательных элементов, количество...
Shariknt
29.07.2019 12:10
Написать программы на паскале. : 1. сгенерировать случайное число, вывести на экран это число, а также сумму и произведение его цифр. 2. вводятся целые числа до первого...
imamverdueffsa
08.05.2020 15:22
Где-то в поле Робота находится прямоугольник, размеры которой неизвестны. Робот из верхнего левого угла поля должен дойти до прямоугольника и закрасить все клетки по...
MaxineCaulfield2003
08.05.2020 15:22
Запишіть вираз z=|x-2|+3x у 8 степені мовою паскаль...
Nadachansky
08.05.2020 15:23
За счет чего произошло резкое уменьшение размеров ЭВМ?...
51Qwerty15
29.09.2019 11:10
Найдите на экране стрелку указатель мыши. полажите ладонь на мышь так, чтобы указательный и средний пальцы свободно легли на кнопки мыши. подвигайте мышь по столу влево,...
Машина0
29.09.2019 09:34
ничего не понимаю40 если можно то подробнее p.s.это всё делается в программе pascal...
Smile460
29.09.2019 11:10
70 переведите целые числа из десятичной системы счисления в восьмеричную 1. 192 2. 300 3. 678 4. 2018 переведите целые числа из десятичной системы счисления в шестнадцатеричную...
Индира1973
29.09.2019 11:10
Какие из следующих событий или процессов можно использовать для передачи или получения информации? запиши в соответствии ячейках да или нет.вспышка света,школьный звонок,восход...
obshaga2311
11.12.2021 13:02
Найдите корень квадратного трёхчлена 5x²-17x+121) 1; -2,4 2) -1; 2,43) 1;2,44) -1; -2,4...
Популярные вопросы
1. исключи лишнее слово. - зима, снег, девочка, папа, стена. - ветер,...
2
Вбанк вложили 50000 под 30% какова величина вклада за 4 года?...
3
Укажите, кто из перечисленных героев на протяжении всего сюжета...
2
Отметь слово в котором все согласные твердые циркач, самолет,марта,...
1
Уездные чиновники приходят к хлестакову...
1
От данных имен существительных образуйте однокоренные существительные...
1
Что движется быстрее скорости света?...
1
650 а+ 70000 кв. мм равно ? кв.м. и кв.дм...
1
Собрали 350 кг яблок и груш и разложили поровну в ящики.получилось...
2
Что означает контекстуальные антонимы?...
1
using namespace std;
int main()
{
setlocale(LC_ALL, "RUSSIAN");
const int arr_len=20;
int arr[arr_len];
int i = 0;
srand(8120);
for (i = 0; i < arr_len; i++)
{
arr[i] = rand() % 100;
cout << arr[i] << ' ';
}
cout << endl;
int min = 100, min_index=arr[0];
for (i = 0; i < arr_len; i++)
{
if (arr[i] < min)
{
min = arr[i];
min_index = i;
}
}
cout << "Минимальный элемент массива: " << min << endl;
cout << "Его индекс: " << min_index << endl;
system("pause");
}