Составьте программу для решения : 1.найдите произведение квадратных корней n первых натуральных чисел 2.определить делится ли сумма цифр заданного натурального числа на 7 3.заменяет в записи натурального числа n цифру 8 на цифру 3

EgorWater EgorWater    3   03.06.2019 23:40    0

Ответы
Vspichka Vspichka  01.10.2020 18:55
1.
var
n, i: integer;
rez: real;
begin
rez:=1;
readln(n);
for i:=1 to n do rez:=rez*sqrt(i);
write(rez);
end.

2.
var
n: string;
i, summa: integer;
begin
readln(n);
for i:=1 to length(n) do summa:=summa+strtoint(n[i]);
if (summa mod 7)=0 then write('Делится') else write('Не делится');
end.

3.
var
n: string;
i, summa: integer;
begin
readln(n);
for i:=1 to length(n) do if n[i]='8' then n[i]:='3';
write(n);
end.

Если возникли вопросы или ошибки в ходе работы программы, пиши в ЛС или комментарии.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика