Составьте программу для pascal abc, решающую следующую . у продавца имеются гири весом 1, 2, 5 кг. наберите минимальное кол-во гирь для взвешивания n кг.

Turtle183119 Turtle183119    1   07.06.2019 00:30    4

Ответы
RihDest RihDest  06.07.2020 22:38
Program z1;
        var n:integer;
        s1,s2,s5:integer;
begin
        write('n=');readln(n);
        s5:=n div 5;n:=n mod 5;
        s2:=n div 2;s1:=n mod 2;
        writeln('5 kg-',s5,';   2 kg-',s2,';   1 kg-',s1);
        readln
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика