tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составьте блок- схему
Составьте блок- схему и программу для определения, что больше-( а-3) или( 2а- и в зависимости от введеного с клавиатуры значения а
kachanovskiyge
2 16.08.2019 23:10
7
Ответы
zhenyakudryash
04.10.2020 23:38
Блок-схема - в прилагаемом файле.
var a:integer;
begin
write('a = ');
readln(a);
writeln('-(a-3) = ',-(a-3));
writeln('(2*a-10) = ',2*a-10);
if -(a-3)>(2*a-10)
then writeln(-(a-3),' > ',(2*a-10))
else writeln((2*a-10),' > ',-(a-3));
end.
Пример:
a = 5
-(a-3) = -2
(2*a-10) = 0
0 > -2
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Subina00
29.09.2019 03:30
ответь на вопрос 1) какие свойства объектов ты знаешь? 2)какие свойства относят к общим свойствам? какие - к отличительным ? 3) всякий ли объект имеет свойства, которые...
дима2852
29.09.2019 03:30
Переведите в двоичную систему счисления все натуральные числа от 1 до 16....
tatianaradoslav
29.09.2019 03:30
Врезультате выполнения фрагмента программы while 0 do begin write (2*(n mod 10)+1); n: =n div 10 end на экране выведено число 13717.укажите все числа,которые могли...
Anastasia74926482
29.05.2019 12:40
Сзадайчей) дано натуральное число x и n найти сумму чисел от x до n...
solodovnikovay124
03.06.2019 02:40
Вчесть дочери поэта дж байрона назвали a) язык програмирования б)эвм в) программу обработки текста г) программу для перевода текста...
16912
03.06.2019 02:40
Программирование в pascalabc. нужно написать программу, которая будет находить сумму двух чисел....
masterplay838oyfq9n
03.06.2019 02:40
Что такое интерактивная презентация...
asyamilos
03.06.2019 02:40
Нельзя отнести к долговременным носителям информации а)дискету б)молекул днк в)радиоволны г)cd-rom...
timcherkasov07p02k8v
04.03.2019 04:50
Переведите в десятичную систему счисления следующие числа: а)(1010,01)16 б)(f001)16...
Dasha555m
03.03.2020 16:45
Яблуня одностатева чи двухстатеві?...
Популярные вопросы
Постройте треугольник. а). острый, б). прямоугольный, в). тупоугольный,...
1
Надо ! решите неравенство (x^2+2x)*(4x-2) =...
2
Какой корень у слов: вермишель, такси шампунь, пианино, картофель,...
3
Втреугольниках abc и a1b1c1 медианы bm и b1m1 равны, ab=a1b1, ac=a1c1....
1
Начертите , 3 разных угла и измерьте транспортиром)...
1
Чему равна скорость танка если он за 8 минут км...
3
Надо уравнение уровнять! ва(он)2+ варо4+ н2о...
1
Почему учащается пульс при нагрузках ?...
2
Вставьте в слове пропущенную букву весё..их (можно и две пропущенные...
3
Основна думка поеми іван вишенський...
2
var a:integer;
begin
write('a = ');
readln(a);
writeln('-(a-3) = ',-(a-3));
writeln('(2*a-10) = ',2*a-10);
if -(a-3)>(2*a-10)
then writeln(-(a-3),' > ',(2*a-10))
else writeln((2*a-10),' > ',-(a-3));
end.
Пример:
a = 5
-(a-3) = -2
(2*a-10) = 0
0 > -2