tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составьте блок-схему и
Составьте блок-схему и опишите на языке программирования алгоритм вычисления площади круга. входные данные вводятся с клавиатуры
shastononelove2
3 22.07.2019 03:20
5
Ответы
vova01092005
07.09.2020 18:29
Да, конечно.
Итак, вот, что нужно добавить в блок-схеме(нарисовать не получится)
Итак, Овал(пустой), стрелочка вниз, паралеллограмм( пишешь r, S, Pi=3.14), Стрелочка вниз, прямоугольник (внутри S=Pi*r*r), стрелка вниз, параллелограмм(S), стрелочка вниз, пустой овал.
Вот программа:
Program KRUG;
var:r, S: real;
const Pi=3.14;
begin
writeln('Введите радиус круга');
read(r);
S:=Pi*sqr(r);
writeln('S=', S);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Seitowad
20.10.2020 20:50
Задание 8. ответьте на вопросы 1. Что представляет собой графический объект в редакторе Flash? 2. Для чего предназначен инструмент Стрелка (Arrow)? 3.Какие операции можно выполнять...
aslanəz
20.10.2020 20:50
Уровень А Закодируй следующие слова, используя таблицу кодирования ASCII. Binary coding; Informatica; Kazakhstan; Rykhani jangyru. Уровень В Посчитай, сколько символов, байтов...
Janne000
20.10.2020 20:50
Сколько бит в памяти компьютера занимает один символ в кодировочной таблице ASCII? Сколько бит в одном байте?...
tcalala
16.07.2019 20:10
Рассмотри, как считлка выполняет алгтритм. начало х : = 2 y : =х+3 х : = х-1 y : = х+y конец какое значение считайка присвоит переменной y в результате выполнения последней команды?...
Kissss1111
16.07.2019 18:03
Сообщение занимает 40 кбайт памяти. мощность алфавита равна 4. сколько символов (в среднем) содержит страница сообщения, если в сообщении 320 страниц?...
ксю882
16.07.2019 20:10
Изобразите в виде графа систему,состоящую из четырех одноклассников,между которыми существуют следующие связи(взаимоотношения): дружат: саша и маша, саша и даша, маша и гриша,...
soymapoIina
13.05.2019 17:05
Найти два числа a и b сообщить имеют ли эти два числа одинаковые или разные знаки. паскаль...
tom159753
13.05.2019 17:03
Найти среднее арифметическое трех чисел. если среднее арифметическое больше 5 то на экран выдать сумму. паскаль...
БабаеваДарья
13.05.2019 17:03
Какая из точек ближе к нулю точки: к, м...
vaneeva06
13.05.2019 17:02
Определите количество кратных трём из а, в и с...
Популярные вопросы
Определите какие средства выразительности используются в отрывке: «под голубыми...
1
Почему человек должен быть ответственным? устный экзамен. 10 аргументов....
3
Какова будет массовая доля повареной соли в растворе если 5 моль ее растворили...
2
Биссектриса одного из углов прямоугольника делит большую сторону пополам. найдите...
1
Запиши все неравенства, имеющие множество решений {8,9,10}...
1
Дан массив из чесел, массив 3х3 (двумерный). найти сумму элементов главной...
3
Придумать маленький рассказ с этими словами: hot, thirsty, sick, well, disgusted...
1
Синтаксический разбор : но она не проснулась, а свернулась в клубочек и по-прежнему...
2
Досыта, изредка, влево, справа, вправо, направо, насухо, наскоро-это словарные...
3
Втреугольнике abc ab=8 корней из 2 угол c=45 градусов a=30 градусов найдите...
1
Итак, вот, что нужно добавить в блок-схеме(нарисовать не получится)
Итак, Овал(пустой), стрелочка вниз, паралеллограмм( пишешь r, S, Pi=3.14), Стрелочка вниз, прямоугольник (внутри S=Pi*r*r), стрелка вниз, параллелограмм(S), стрелочка вниз, пустой овал.
Вот программа:
Program KRUG;
var:r, S: real;
const Pi=3.14;
begin
writeln('Введите радиус круга');
read(r);
S:=Pi*sqr(r);
writeln('S=', S);
end.