Составить программы по информатике, препод - зверь.

pascal

1. найдите длину на отрезке [a,b], заданного координатами точек а и в.

2. найдите произведение дробей z+5/ [10..l].

3. найдите произведение элементов массива а [1..10] больше первого элемента.

4. найдите максимальную температуру первой декады ноября.

5. найдите среднюю зарплату 20-ти сотрудников офиса.

, хотя бы с парочкой! т.т

natka73 natka73    2   16.12.2019 22:01    2

Ответы
ArtLeg ArtLeg  10.10.2020 21:06

Объяснение:

1.

program line_AB;

uses crt;

var L, xa, xb, ya, yb:real;

begin

WriteLn('Найдем длину отрезка АВ по координатам его крайних точек' );

Writeln('Введите координаты точки A');

Write('x = ');ReadLn(xa);

Write('y = ');ReadLn(ya);

Writeln('Введите координаты точки B');

Write('x = ');ReadLn(xb);

Write('y = ');ReadLn(yb);

L:=sqrt(sqr(xb-xa)+sqr(yb-ya));

Write('Длина отрезка AB равна ', L);

readln;

end.

2.

program MultDrob;

uses crt;

var z, mult:real; i, L:Integer;

begin

Write('Введите Z = ');ReadLn(z);

Write('Введите L = ');ReadLn(l);

mult:=z+5/(10);

for i:=1 to l do

mult:=mult*(z+5/(10+i)) ;

Write('Произведение дробей z+5/[10..L] равно ', mult);

readln;

end.

3.

program MultMass;

uses crt;

var A:array[1..10] of real; mult:real; i:Integer;

begin

Randomize;

for i:=1 to 10 do begin

a[i]:=Random(10);

write(a[i]:7:2) end;

WriteLn;

mult:=1;

for i:=2 to 10 do

if a[i] > a[1] then mult:=mult*a[i] ;

if mult>1 then Write('Произведение элементов болших первого равно ',mult)

else Write('Произведение элементов болших первого равно ' ,0);

readln;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика