Составить программы для 3 – 5 3. найти сумму чётных чисел из натурального ряда от 1 до 1000? 4. дано nчисел. написать программу, находящую номер самого большого числа. 5. в кассе имеются купюры достоинством в к рублей и 1 рубль. выдать n рублей минимальным набором купюр заданного достоинства. кому не сложно (

Полина1111111С Полина1111111С    2   30.08.2019 09:40    1

Ответы
nargis1077 nargis1077  06.10.2020 04:48
3.

Var S,i:integer;
Begin
S:=0;
For i:= 1 to 1000 do
    if i mod 2 = 0 then S:=S+i;
WriteLn('S = ',S)
End.

Результат работы программы:
S = 250500

4.

Var
   N,A,i,Max:integer;
Begin
Write('N = ');ReadLn(N);
Write('Введите целые числа(',N,' шт.):');
Read(Max);
i:=1;
For N:= 2 to N do
    Begin
    Read(A);
    if A > Max then
       Begin
       Max:=A;
       i:=N
       End;
    End;
WriteLn('Максимум: ',Max);
WriteLn('Номер максимума: ',i);
End.

Пример работы программы:

N = 7
Введите целые числа(7 шт.):1 2 3 5 9 4 7
Максимум: 9
Номер максимума: 5

5.

Var K,N:integer;
Begin
Write('K = ');ReadLn(K);
Write('N = ');ReadLn(N);
WriteLn('Количество купюр по ',K,' руб.: ',N div K);
WriteLn('Количество купюр по 1 рублю: ',N mod K);
End.

Пример работы программы:

K = 38
N = 3000
Количество купюр по 38 руб.: 78
Количество купюр по 1 рублю: 36
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика