Составить программувысота сосны в начале года 1.8 м, а к концу года она увеличилась на 15%. какая будет высота через "n" лет, если ее прирост за каждый следующий год= 90 % от прироста предыдущего

rlimiksklimukh rlimiksklimukh    2   26.05.2019 02:30    1

Ответы
аня2941 аня2941  22.06.2020 11:16
Program first;
var a,b:real; n:integer;
begin
readln(n);
if n=0 then begin
writeln('Сосна почти не выросла за этот промежуток времени');
exit;
a:=1,8;
b:=(1,8*15)/100;
for i:=1 to n-1 do
b:=b+((b*90)/100);
writeln('Висота сосны через ',n,' лет равна', a+b);
end.
ПОКАЗАТЬ ОТВЕТЫ
Foksit2006 Foksit2006  22.06.2020 11:16
Написано на Pascal:

Program Sosna;
Var a, b: Real;
n, i: Integer;
Begin
a := 1.8;
Write('n = ');
ReadLn(n);
b := a * 0.15;
a := a + b;
For i := 1 To n Do
Begin
b := b * 0.9;
a := a + b;
End;
WriteLn('Высота сосны через ', n,' лет будет ', a:10:2, ' м.');
ReadLn;
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика