Составить программу заполняя масива из 100 чисел случаиними значениями -20 до 20 . почитать количество отрецательних и положительних чисел .

chizhikovilya chizhikovilya    2   27.08.2019 00:40    7

Ответы
sensed sensed  14.08.2020 20:50
Var A:array[1..100] of integer;
i,Ko,Kp:integer;
Begin
Ko:=0;
Kp:=0;
Write('Исходный массив: ');
For i:= 1 to 100 do
    Begin
    A[i]:=random(41)-20;
    Write(A[i],' ');
    if A[i]<0 then Ko:=Ko+1
    else if A[i]>0 then Kp:=Kp+1;
    End;
WriteLn;
WriteLn('Количество отрицательных: ',Ko);
WriteLn('Количество положительных: ',Kp);
End.
ПОКАЗАТЬ ОТВЕТЫ
poshel0naher poshel0naher  14.08.2020 20:50
Var
  arr : array [1.. 100] of integer;
  i, sum1, sum2 : byte;
 
begin
Randomize();
for i := 1 to 100 do
  begin
  arr[i] := random(-20, 20);
  if arr[i] < 0 then
  sum1 += 1
  else if arr[i] > 0 then
  sum2 += 1
  end;writeln('Количсетво отрицательных чисел: ', sum1);
writeln('Количество положительных чисел: ', sum2);end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика