tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу, выводящую
Составить программу, выводящую числа от 70 до 100, которые нечетные и делятся на 3. найти их сумму и количество этих чисел.
vzlomhanter230
3 21.09.2019 05:40
4
Ответы
Сос1111111
08.10.2020 06:25
// PascalABC.NET 3.3
begin
var a:=Range(70,101).Where(i->(i mod 2=1)and(i mod 3=0)).
ToArray.Println;
writeln('s = ',a.Sum,' k = ',a.Count);
end.
Результат:
75 81 87 93 99
s = 435 k = 5
ПОКАЗАТЬ ОТВЕТЫ
228УЕБАН228
08.10.2020 06:25
C++
//g++ 5.4.0
#include <iostream>
using namespace std;
int main()
{
size_t sum = 0, count = 0;
for (size_t i = 71, c = 1; i <= 100; i += 2, ++c) {
cout << i << " ";
sum += i;
count = c;
}
cout << endl << sum << " / " << count << endl;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
danyok132006
29.07.2019 07:50
Население города едегодно увеличивается на 1/40 наличного состава жителей ( сейчас в нем 240 000) через сколько лет население города утроится? pascal...
Dyhanexis
15.05.2020 21:48
Найдите значения выражений: (0 v 1)а) 1 v 0 & 1 & 1 & 0 v 1 б) ((1 v 0) & (1 & 1))...
aizhanashoznweb
15.05.2020 21:48
Гиперссылки на страницы, расположеные на удалённых web узлах ответьте оценю в 5 звёзд! Это сор...
Drake1111
15.05.2020 21:49
Напишите программу, которая вычисляет площадь прямоугольника по длинам двух его сторон....
89370982401
08.12.2020 23:56
5. ответить на вопросы по данному рисунку1. a. Какие инструменты использованы для создания многогранного объекта?b. В какой сфере (области) показан создаваемый объект и для чего...
SkeCreeper
08.12.2020 23:56
Определите в скольких случаях выражение принимает истинное значение...
ирпимрпмро
25.09.2019 03:10
Программисты, нужно написать программу на паскале. приписать по 1 в начало и конец числа n. например, из числа n=5678 надо получить 156781. с longint ....
котак5
25.09.2019 03:10
Составить алгоритм и программу на паскале, позволяющую найти сумму натуральных чисел, кратных 12, в диапазоне от 1 до 70...
alsuaxmetzan
25.09.2019 03:10
Документ объемом 16 мб можно передать по сети двумя а. сжать архиватором, передать архив по каналу связи, распаковать. б. передать по каналу связи без использования архиватора....
007ek
19.10.2021 08:01
сегодня до 18:00 11.В одной из кодировок Unicord символ кодируется 16 битами. Определите размер битов если символов:(в прикреплённом файле)...
Популярные вопросы
Предмет высотой 1,2 см поставлен перпендикулярно оптической оси и удален от двояковыпуклой...
1
Complete the sentences with the Past Simple form of the verbs. 1)When we last...
1
- Определите, какие средства художественной выразительности использованы в каждом...
2
Задание 1. Вычислите sinα, если соsα = 0,28 и α принадлежит IV четверти. Задание...
1
R=18 Ом,R1=3 Ом, R2=2 Ом,R3=1 Ом...
1
1963 1900 2010 2021 переведите эти даты на английский используя только слова...
3
, русский язык упражнение 183...
1
Укажите слово, в котором нет чередующейся гласной в корне: А. коснуться; Б. переписать;...
2
В школьной библиотеке 2 465 книг.456 книг раздали учащимся,а остальные книги...
2
1. Кто - это какая часть речи? 2. Это - какая часть речи?...
3
begin
var a:=Range(70,101).Where(i->(i mod 2=1)and(i mod 3=0)).
ToArray.Println;
writeln('s = ',a.Sum,' k = ',a.Count);
end.
Результат:
75 81 87 93 99
s = 435 k = 5
//g++ 5.4.0
#include <iostream>
using namespace std;
int main()
{
size_t sum = 0, count = 0;
for (size_t i = 71, c = 1; i <= 100; i += 2, ++c) {
cout << i << " ";
sum += i;
count = c;
}
cout << endl << sum << " / " << count << endl;
}