Составить программу. вывести с клавиатуры целое число,и определить,есть ли в нем повторяющиеся цифры.программа должна вывести"да" или "нет". заранее .

Wowan07 Wowan07    3   13.07.2019 16:40    8

Ответы
grenzygaming grenzygaming  20.09.2020 06:46
Uses crt;
var s:string;
i:integer;
l:boolean;   
m:set of char;
begin clrscr;
write('Введите число :');
readln(s); l:=false;
for i:=1 to length(s) do begin 
if  (m<>m-[s[i]]) then l:=true;
m:=m+[s[i]];
end;
if l then Writeln('Да')     
else Writeln('Нет');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика