Составить программу, вычисляющую площадь фигуры. тип фигуры определяется символом (с): о – окружность, t – равнобедренный прямоугольный треугольник и k – квадрат. целое число, вводимое вслед за символом определяет соответствующий элемент для вычисления площади (для окружности это радиус, для треугольника – длина катета, для квадрата – длина стороны).

kolyapauk2016p08ax4 kolyapauk2016p08ax4    2   16.07.2019 20:50    18

Ответы
STOORIK STOORIK  21.09.2020 13:00
Var
S, X, a, b, R: Real;
C: String;
Begin
WriteLn('Chto budem vichislat');
ReadLn(C);
if C = 'O' then begin
WriteLn('Radius');
ReadLn(R);
S:= Pi*sqr(R);
end;
if C:= 'T' then begin
WriteLn('Vvedite 1 katet);
ReadLn(a);
WriteLn('Vvedite 2 katet);
ReadLn(b);
S:= 1/2 * a * b;
end;
if C:= 'K' then begin
WriteLn('Vvedite 1 katet);
ReadLn(a);
S:= sqr(a);
end;
WriteLn('Ploshad = ');
ReadLn(S);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика