Составить программу, вычисляющую количество элементов двумерного массива, размерности 3 на 4, больших заданного числа.. паскаль

kolisnyk98 kolisnyk98    1   26.02.2022 11:17    10

Ответы
Light111111 Light111111  26.02.2022 11:20

Программа:

Pascal:

var

 arr: array[1..3, 1..4] of integer;

 i, j, n, count: integer;

begin

 write('Введите число: '); readln(n);  // ввод числа n

 for i := 1 to 3 do

   for j := 1 to 4 do begin

     arr[i, j] := random(100);  // заполнение массива случайными числами от 0 до 100

     if arr[i, j] > n then  // если число больше заданного числа, то...

       count += 1;  // увеличиваем значение переменной count на 1

   end;

 writeln('Массив: ', arr);  // вывод массива

 writeln('Чисел, больше ', n, ': ', count);  // вывод кол-ва элементов, больше n.

end.

Чтобы заполнить массив, для начала нужно выделить ему память. После этого запрашивает значение "заданного числа" n. После выделения памяти и запроса числа нужно в двойном цикле обойти все ячейки массива (i - номер строки, j - номер столбца). После начала цикла сначала заполняем массив случайными числами (от 0 до 100), а после находим количество элементов, больше заданного числа. В конце выводим сам массив и кол-во элементов, больше заданного числа.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика