Составить программу вычисления значений квадратичной функции на заданном интервале

Cet31072007 Cet31072007    3   25.06.2019 17:40    2

Ответы
gyukk gyukk  20.07.2020 19:24
Var
  a,b,c,p,q,h,x,y:real;
begin
  Write('Введите через пробел коэффициенты a,b,c: ');
  Read(a,b,c);
  Write('Введите через пробел границы интервала [p;q]: ');
  Read(p,q);
  Write('Введите шаг табуляции h: ');
  Read(h);
  x:=p;
  while x<=q+h/10 do begin
    y:=c+x*(b+x*a); { схема Горнера для вычисления значения полиномов }
    Writeln(x:15:8,y:15:8);
    x:=x+h
  end
end.

Тестовое решение:
Введите через пробел коэффициенты a,b,c: -4 2.7 10.582
Введите через пробел границы интервала [p;q]: -3 2.5
Введите шаг табуляции h: 0.25
    -3.00000000   -33.51800000
    -2.75000000   -27.09300000
    -2.50000000   -21.16800000
    -2.25000000   -15.74300000
    -2.00000000   -10.81800000
    -1.75000000    -6.39300000
    -1.50000000    -2.46800000
    -1.25000000     0.95700000
    -1.00000000     3.88200000
    -0.75000000     6.30700000
    -0.50000000     8.23200000
    -0.25000000     9.65700000
     0.00000000    10.58200000
     0.25000000    11.00700000
     0.50000000    10.93200000
     0.75000000    10.35700000
     1.00000000     9.28200000
     1.25000000     7.70700000
     1.50000000     5.63200000
     1.75000000     3.05700000
     2.00000000    -0.01800000
     2.25000000    -3.59300000
     2.50000000    -7.66800000
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика