Составить программу вычисления, w=b+(a-b): (c+1) a сумма положительный элементов массива b количество отрицательных элементов массива c произведение элементов массива с нечетными номерами полученные значения элементов a,b,c,w вывести на печать.

tarnopolska99 tarnopolska99    1   04.10.2019 18:20    3

Ответы
Михайлов11 Михайлов11  09.10.2020 20:11

const N=1000;

var K: array [1..N] of integer;

i,A,B,C: integer;

W: real;

begin

for i:=1 to N do K[i]:=random(101)-50;

A:=0;

B:=0;

C:=1;

for i:=1 to N do begin

if K[i]>0 then A:=A+K[i];

if K[i]<0 then B:=B+1;

if i mod 2<>0 then C:=C*K[i];

end;

W:=B+(A-B)/(C+1);

writeln(W);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика