Составить программу вычисления суммы элементов массива а, значения которых меньше чем -0,5. проверить работу программы за заданном массиве а(11). паскаль

natalimironenko natalimironenko    3   24.09.2019 04:20    1

Ответы
katerinamorozo2 katerinamorozo2  08.10.2020 14:05
Var
a: array[1..100] of real;
i,n:Integer;
sum: real;
begin
WriteLn('Введите количество элементов массива');
Readln(n);
WriteLn('Массив');
for i:=1 to n do
begin
a[i]:=(random(100)-50)/10;
Write(a[i]:5);
if a[i]< -0.5 then sum:=sum +a[i];
end;
Writeln;
Writeln('Сумма элементов меньших -0,5 = ', sum);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика