Составить программу вычисления суммы чисел, делящихся на 4 от 1 до N. Используйте цикл while.

hovrashok hovrashok    2   18.05.2020 09:24    6

Ответы
samininav1 samininav1  14.10.2020 21:53

Напишу сначала на простом языке по пунктам, потом на питоне:

считать N

x = 0 (счётчик)

s = 0 (сумматор)

пока x не равен N делать

x = x + 1

если x делится на 4, то s = s + x

цикл закончился

выводим s

Python:

n = int(input())

x = 0

s = 0

while x != n:

  x += 1

  if x % 4 == 0:

        s += x

print(s)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика