Составить программу вычисления произведения положительных и суммы отрицательных элементов массива a.проверить работу программы на заданном массиве a(11). на паскале

ochensad ochensad    1   24.09.2019 05:50    5

Ответы
alena7571 alena7571  08.10.2020 14:23
Program p1;
uses crt;
var a:array[1..11] of integer;
i,p,s:integer;
begin

for i:=1 to 11 do begin
 a[i]:=random(30)-10;
 write(a[i]:4);
 end;
    p:=1;
 s:=0;
  for i:=1 to 11 do begin

    If a[i]>0 then begin
      p:=p*a[i];
     end;
     
     If a[i]<0 then
      s:=s+a[i];
      end;
writeln;
writeln('Произведение  :',p);
writeln('Сумма :',s);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика