Составить программу вычисления количества положительных, кратных 5 элементов массива, состоящего из 25 целых чисел

MatthewSan MatthewSan    1   16.12.2019 10:14    8

Ответы
ValeriaIv ValeriaIv  10.10.2020 20:54

var a:array [1..25] of integer;

i,k:integer;

begin

write('Массив ');

for i:=1 to 25 do

begin

a[i]:=random(31)-15;

write(a[i]:5);

if (a[i] mod 5 = 0) and (a[i]>0) then k:=k+1

end;

writeln;

write('Количество положительных, кратных 5, элементов массива равно ',k)

end.

ПОКАЗАТЬ ОТВЕТЫ
Саша23458 Саша23458  10.10.2020 20:54

===== PascalABC.NET =====

begin

 var a := ArrRandom(25, -99, 99);

 a.Println;

 a.Count(p -> (p > 0) and (p mod 5 = 0)).Println

end.


Составить программу вычисления количества положительных, кратных 5 элементов массива, состоящего из
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика