tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу вычисления
Составить программу вычисления функции y=1- при изменении аргумента x в интервале с шагом h=0.1
5БЭкибастузшкола35
1 22.08.2019 14:20
6
Ответы
rot3
05.10.2020 12:43
Число повторений цикла = целая часть [(3-0.1)/0.1]+1 = 30
// PascalABC.NET 3.2, сборка 1383 от 09.02.2017
begin
for var i:=1 to 30 do begin
var x:=0.1*(i-1)+0.1; var y:=1-sin(x)/(1-ln(x+0.1));
Writeln(x:3:1,y:15:5)
end
end.
Результат
0.1 0.96174
0.2 0.90986
0.3 0.84579
0.4 0.77000
0.5 0.68267
0.6 0.58380
0.7 0.47331
0.8 0.35102
0.9 0.21667
1.0 0.06988
1.1 -0.08992
1.2 -0.26355
1.3 -0.45217
1.4 -0.65751
1.5 -0.88208
1.6 -1.12960
1.7 -1.40571
1.8 -1.71913
1.9 -2.08389
2.0 -2.52355
2.1 -3.08055
2.2 -3.83866
2.3 -4.98810
2.4 -7.06916
2.5 -12.45227
2.6 -75.39064
2.7 15.42904
2.8 6.17670
2.9 3.42616
3.0 2.07396
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
kimas98
11.04.2020 11:42
Пусть а, b, c – углы треугольника. Какое сообщение можно вывести на экран при выполнении условия (a = 90) or (b = 90) or (c = 90)?1)Треугольник прямоугольный2)Треугольник равносторонний3)Нет...
Lumperz
13.04.2020 19:30
Дан фрагмент программы : х: =52 write (ответ х км/ч) После его выполнения на экран будет выведено...
joraninga
15.04.2019 12:31
Ketogenic accelerator utilization of ketogenic accelerator is basic as it has cases which can be overwhelmed by typical water for the most part it is referenced that admission...
smail130
15.04.2019 12:31
Таблица истинности. решить уравение...
Kpuc2100
15.04.2019 12:29
Как написать презинтацию на тему животные...
onpapion
15.09.2019 18:01
Какую текстовую информацию нецелесообразно оформлять в табличной форме 5 примеров....
MaarioForte
15.09.2019 18:01
Какие на ваш взгляд потенциальные угрозы несет информационное общество?...
KosherDan
15.09.2019 18:01
Перечислите вставки в текстовый документ таблиц, рисунков, диаграмм....
Subhinur
15.09.2019 18:03
Существуют ли в современной отечественной культуре общепринятые нормы, принципы сетевого этикета, каковы они?...
MRSinn
15.09.2019 18:03
10111 из 2 -ной в 10-ную. как решать?...
Популярные вопросы
Определите степени окисления в бинарных соединениях: mg3n2,kf,cu3p,fe2s3потом...
1
Choose the right tense form to make the sentences complete (past simple,...
1
Анализ стиха николай заболоцкий вечер на оке только не списано с инета подал...
3
Плотность паров одноосновной карбоновой кислоты по водороду равна 37. какова...
1
На какой горе держал небосвод титан атлас? 30...
1
Напишите 3 предложения о своем будущем доме на ....
1
Написати презентацію мій улюблений твір зарубіжних письмеників має бути тема,...
2
Установіть послідовність подій за комедією мартин боруля...
3
Объем комнаты 72куб.м. высота комнаты 3м. найдите площадь пола, если ее длина...
2
Baphant 08english variant no 8*3 choose the answer which correctlycompletes...
1
// PascalABC.NET 3.2, сборка 1383 от 09.02.2017
begin
for var i:=1 to 30 do begin
var x:=0.1*(i-1)+0.1; var y:=1-sin(x)/(1-ln(x+0.1));
Writeln(x:3:1,y:15:5)
end
end.
Результат
0.1 0.96174
0.2 0.90986
0.3 0.84579
0.4 0.77000
0.5 0.68267
0.6 0.58380
0.7 0.47331
0.8 0.35102
0.9 0.21667
1.0 0.06988
1.1 -0.08992
1.2 -0.26355
1.3 -0.45217
1.4 -0.65751
1.5 -0.88208
1.6 -1.12960
1.7 -1.40571
1.8 -1.71913
1.9 -2.08389
2.0 -2.52355
2.1 -3.08055
2.2 -3.83866
2.3 -4.98810
2.4 -7.06916
2.5 -12.45227
2.6 -75.39064
2.7 15.42904
2.8 6.17670
2.9 3.42616
3.0 2.07396