Составить программу вычисления двузначного числа, сумма кубов цифр которого равна n.

Pincode11 Pincode11    2   02.09.2019 13:50    2

Ответы
kitty67 kitty67  06.10.2020 12:24
// PascalABC.NET 3.2, сборка 1456 от 26.05.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('n=');
  var s:=Range(10,99).Where(x->(Power(x div 10,3)+Power(x mod 10,3)=n));
  if s.Count>0 then s.Println
  else Writeln('Нет таких чисел')
end.

Пример
n= 9
12 21
ПОКАЗАТЬ ОТВЕТЫ
ppp13 ppp13  06.10.2020 12:24
Var
   a,b,k:byte;
   n:integer;
Begin
Write('n = ');ReadLn(n);
k:=0;
For a:= 1 to 9 do
    For b:= 0 to 9 do
        if a*a*a+b*b*b = n then
           Begin
           Write(a,b,' ');
           k:=k+1
           End;
if k = 0 then Write('Таких чисел не существует.')
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика