Составить программу вычисления, a - сумма положительных элементов массива; b - количество отрицательных элементов массива; c - произведение элементов массива с нечетными номерами. полученные значения элементов а,b,c,w вывести на печать. паскаль!

Айринчик Айринчик    2   03.10.2019 14:01    3

Ответы
Лара505 Лара505  10.09.2020 23:56

const n=10;

var m:array [1..n] of integer;

i,A,B,C:integer;

begin

C:=1;

write('Массив: ');

for i:=1 to n do

begin

m[i]:=random(41)-20;

if m[i] > 0 then A:=A+m[i];

if m[i] < 0 then B:=B+1;

if i mod 2 <> 0 then C:=C*m[i];

write(m[i],'  ')

end;

writeln;

writeln('Сумма положительных элементов: ',A);

writeln('Количество отрицательных элементов: ',B);

writeln('Произведение элементов массива с нечетными номерами: ',C);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика