Составить программу в с++: создать функцию square (x) нахождение его площади квадрата и функцию maxi (x, y) нахождение наибольшего из двух значений. дано сторону квадрата. составить программу с использованием функции square и maxi, которая для двух квадратов, будет находить тот, площадь которого больше и выводить значение большей площади на экран.

Режик Режик    3   17.09.2019 12:50    3

Ответы
christihhh75 christihhh75  07.10.2020 21:49
#include <iostream>
using namespace std;

double square(double x) {
   return x*x;
}

double maxi(double x, double y) {
  if (x>y)
     return x;
  else
     return y;
}

int main() {
   double a1,a2,s1,s2;
   cin >> a1 >> a2;
   cout << "s=" << maxi(square(a1),square(a2)) << endl;
   return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика