Составить программу в с++, печатающую значение true , если указанное высказывание является истинным , и false в противном случае : числа a и b выражают длины катетов одного прямоугольного треугольника , а c и d - другого . эти треугольники являются подобными . на языке с ++

alwina347 alwina347    3   25.06.2019 16:30    5

Ответы
irfanmirzoev2 irfanmirzoev2  20.07.2020 18:51
#include <iostream>
using namespace std;

int main()
{
    double a,b,c,d;
    cout << "Enter 1st-triangle catheti here: " << endl;
    cin >> a >> b;
    cout << "Enter 2nd-triangle catheti here: " << endl;
    cin >> c >> d;

    bool podobie = ((a/c == b/d) || (a/d == b/c));

    cout << boolalpha;
    cout << podobie;
    
    cin.get();
    cin.get();
    return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика