tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу в с++ дан
Составить программу в с++ дан массив размера n и целые числа k и l (1 < k ≤ l ≤ n). найти сумму всех элементов массива, кроме элементов с номерами от k до l включительно.
aikosha9
3 02.09.2019 20:10
1
Ответы
dawesmm
06.10.2020 13:06
#include <iostream>#include <iomanip>#include <ctime>
using namespace std;
int main(){ setlocale(LC_ALL, "RUSSIAN"); const int N = 10; int arr[N]; int K, L, sum = 0, sumexcl = 0; srand(time(NULL)); for (int i = 0; i < N; i++) { arr[i] = rand() % 10; sum += arr[i]; } cout << "Введите K >> "; cin >> K; cout << "Введите L >> "; cin >> L; for (int i = 0; i < N; i++) { cout << arr[i] << " "; if((i>=K) && (i<=L)) sumexcl += arr[i]; } sum -= sumexcl; cout << "Результат: " << sum << endl; system("pause");}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
seryakovart
31.12.2020 16:19
из каких комлектующих состоит системник искра от IBM (ЭВМ...
turarernur
31.12.2020 15:40
Каретка стоит на нулевой ячейке. Метки расположены через одну правее каретки. Нужно посчитать сколько всего меток, то есть сделать массив меток такой длины, сколько меток находится...
vladimirovna121
31.12.2020 15:24
Пайтон Потрібно накопичити суму чисел, що дорівнюєРІВНО 100 з випадкових чисел від 1 до 10• Якщо сума стає більша за 100, то починаємо зпочатку (сума рівна 0)...
никитаррр1
31.12.2020 15:14
Написать программу, которая выводит сумму цифр двухзначного числа. Например, при вводе в программу числа 54 на экран выведется число 9. C++...
colins1987
10.12.2019 18:24
Кроссворд на тему компьютер ! ! заранее ...
Vika1568393hhhu
10.12.2019 18:22
Всимфонический оркестр приняли на работу трёх музыкантов: вадима, стаса и михаила, умеющих играть на скрипке, флейте, альте, кларнете, гобое и трубе. известно, что: стас самый высокий;...
tecakrus88
13.08.2019 16:50
Какие файлы относятся к графическим...
nastya84756
13.08.2019 16:50
Исполнитель чертёжник перемещается на координатной плоскости, оставляя след в виде линии. чертёжник может выполнять команду сместиться на (a, b) (где a, b – целые числа), перемещающую...
ostapenkonatasha
08.12.2022 04:09
Файл, содержащий черно-белый (без оттенков серого) растровый квадратный рисунок, имеет объем 200 байт. Рассчитайте размер стороны квадрата (в пикселях)....
9438dima
07.12.2022 21:50
В файле записаны сведения о детях в детском саду: Абай Касымович 5 лет Сведения о возрасте самых старших и самых младших детей необходимо записать в текстовый файл....
Популярные вопросы
сообщение: учеба как вид деятельности...
3
Знатоки решить...Найдите f (x0), когда...
3
«Идеал красоты в представлении разных героев романа Г. Сенке- вича Камо грядеши”,...
3
6 кл не сложно Биология Каково значение спор в жизни папоротника...
2
4. Складіть формули бінарних сполук елементів та запишіть їх у таб- лицю, дотримуючись...
3
Монолог по английскому extreme sports...
2
Установите соответствие между уравнением реакции и степенью окисления частицы,...
3
1.Анимация, в которой ключевыми являются первый и последний кадры, а генерация...
2
В квадрате 3х3 клетки провели отрезки AB и CD так, как это показано на рисунках....
2
Отметьте программы, относящиеся к прикладному программному обеспечению: Офисные...
2
using namespace std;
int main(){ setlocale(LC_ALL, "RUSSIAN"); const int N = 10; int arr[N]; int K, L, sum = 0, sumexcl = 0; srand(time(NULL)); for (int i = 0; i < N; i++) { arr[i] = rand() % 10; sum += arr[i]; } cout << "Введите K >> "; cin >> K; cout << "Введите L >> "; cin >> L; for (int i = 0; i < N; i++) { cout << arr[i] << " "; if((i>=K) && (i<=L)) sumexcl += arr[i]; } sum -= sumexcl; cout << "Результат: " << sum << endl; system("pause");}