Составить программу в паскале. тестируется группа из n человек. каждый вводит 1,если изучает ,2-,3-французский,0-никакой. определить сколько человек в каждой языковой группе. с операторами for и case.

asdgvhmh asdgvhmh    1   13.08.2019 05:50    2

Ответы
Chinchil1a Chinchil1a  04.10.2020 15:11

var
n,i,otv,l,m,h,k: integer;
begin
writeln ('сколько человек в группе');
read (n);
for i:=1 to n do
begin
writeln ('какой язык ты изучаешь: 1-англ,2-нем,3-франц,0-никакой');
read (otv);
case otv of
0: l:=l+1;
1: h:=h+1;
2: k:=k+1;
3: m:=m+1;
end;
end;
writeln ('английский язык изучает',h,'человек');
writeln ('немецкий язык изучает',k,'человек');
writeln ('французский язык изучает',m,'человек');
writeln (l,'человек не изучает никакой язык');
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика