Составить программу в паскале: найти наибольшее целое n такое что : a) 3n^4-730n< 5 b) e^n-1000ln*n< =10

Настюля151 Настюля151    2   04.06.2019 04:50    8

Ответы
13372225 13372225  05.07.2020 09:17
1) Если использовать последний Паскаль АВС, который умеет вычислять степень (Power), то вот вариант программы:
var
   n:integer;
   s:real; {вообще, он целый, но мой компилятор не пропускает, почему-то считает, что                 результат вычислений будет real}
begins:=0;
n:=1;
while s<5 do 
   begin
   s:=3*power(n,4)-730*n; {для старого Паскаля напиши так: s:=3*sqr(sqr(n))-730*n}
   n:=n+1
end;
writeln(n)
end.

2)
var n,s:real;
begin
s:=0;
n:=1;
while s<=10 do
   begin
   s:=exp(n)-1000*Ln(n);
   n:=n+1
   end;
writeln(n)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика