Составить программу в паскале которая проверяет наличие введенного слова в строке

polina200412 polina200412    3   26.07.2019 04:11    2

Ответы
liza9novxp011he liza9novxp011he  24.09.2020 19:42
Так как в задании не указано, что введенное слово должно обрамляться пробелами, то код может быть такой:

var s,a:string;
    begin
    write('Введите строку : ');
    readln(s);
    write('Введите слово : ');
    readln(a);
       if(pos(a, s) <> 0) then writeln('Слово "',a,'" в строке есть')
       else writeln('В строке такого слова нет');
    end.

Тест №1
Введите строку : Привет участникам олимпиады!
Введите слово : ник
Слово "ник" в строке есть

Тест №2
Введите строку : Всем привет!
Введите слово : админ
В строке такого слова нет
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика