tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу в паскале
Составить программу в паскале которая ,находит среднее арифметическое натуральных чисел, меньших 200 и кратных 7.
ArtemDeineka
2 29.05.2020 14:35
7
Ответы
Breake090
15.10.2020 11:00
begin
Range(7, 200, 7).Average().Print();
end.
//PascalABC.NET 3.5.X
ПОКАЗАТЬ ОТВЕТЫ
Сашунязайка
15.10.2020 11:00
begin(1..199).Where(x -> x mod 7 = 0).Average.Printend.
или
var i,s,n: integer;beginwhile i+7<200 dobegini := i + 7;s := s + i;n := n + 1;end;write(s/n);end.
Пример работы:
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
ktoya2
27.04.2020 01:37
Выберите правильные варианты вывода элементов массива на печать в строку. a. for i:=1 to n do writeln (a[i]); b. for i:=1 to n do write (`a[`, i, `]=`); c. for i:=1 to n...
Alekskarpov
27.04.2020 01:37
Постройте ориентированный граф автомата Мура, продающего кофе. Кофе с сахаром стоит 14 рублей, без сахара – 13. Автомат принимает купюры по 10 рублей и монеты по 1, 2 и 5...
stanislavvolk8
20.09.2019 20:10
1. дайте определение понятия алгоритм - это...
dilasagadatova
18.05.2019 12:10
Среди двухзначных чисел найти сумму квадратов цифр которых делится на 13 составить программу с ! пааскаль...
mazaso
18.05.2019 12:10
Найти 18+19+20+21+22+23 с использованием оператора цикла....
sagynnn
18.05.2019 12:10
Где используется технология гипертекста? как визуально определяется гиперсылка в тексте? между какими объектами устанавливается связь при создании гиперссылок? как осуществляется...
olena345678644
21.07.2022 18:31
Программа запрашивает ввод числа участников и печатает каждому бейджик. Бейдж содержит название олимпиады: «-Золотое пёрышко-», поле для имени: «Имя: » и поле для школы:...
demid13123456789
21.07.2022 19:12
Вводяться 10 чисел користувачом. Знайти суму та середнє арифметичне цих чисел. (while) c++...
JafarSafarov
19.02.2020 19:20
Як написати програму мовою паскаль яка буде рахувати кількість унікальніх букв у слові...
sashunyakotova
22.04.2020 09:16
Что такое под цифрой 8 и 12...
Популярные вопросы
Найти радиус окружности с центром в точке О,если углы между касательными-60...
1
Напомните о своей своим родителям (вы просили купить новые джинсы)....
3
решить графически систему уравнений...
1
В треугольнике ABC, A= C-28°, B: C= 8:9. Найдите углыэтого треугольника....
2
Чем отличаются названия материков от частей света...
3
Письменно дать развернутый ответ на вопрос: что общего между героями Алешей,...
2
Look at the pictures and match the words to make expressions light gifts...
3
1. Қара және түсті металдарды өңдеудің ұқсастықтары мен айыр-машылықтары...
3
К возобновляемым источникам энергии относятся: ...
2
3. Найдите в историко-биографическом произведении Тарих-и-Рашиди Мирзы...
2
begin
Range(7, 200, 7).Average().Print();
end.
//PascalABC.NET 3.5.X
или
var i,s,n: integer;beginwhile i+7<200 dobegini := i + 7;s := s + i;n := n + 1;end;write(s/n);end.Пример работы: