Составить программу в паскале.даны три положительных числа а,в,с. проверить, могут ли быть они длинами сторон треугольник. если да, то вычислить площадь треугольника. (нужно учитывать, что стороны не могут равняться нулю. и возможно существование равностороннего треугольника) основные формулы: а< =б+с, б

крмоири крмоири    1   19.05.2019 01:10    6

Ответы
dron4ik226 dron4ik226  12.06.2020 06:31

var a,b,c,p:integer;
begin
  writeln('введите a');
   readln(a);
  writeln('введите b');
   readln(b);
  writeln('введите c');
   readln(c);
  if (a<=b+c) and (b<a+c) and (c<=a+b) then
    begin
       p:=(a+b+c) div 2;
       writeln('Треугольник может существовать');
       writeln('Площадь: ', sqrt(p* ((p-a)*(p-b))*((p-c))):1:2);  //Формула герона
    end
  else writeln('Не треугольник');
  readln();
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика