составить программу в Паскале.
Дано трехзначное (пятизначное, десятизначное) число. Постройте новое число, состоящее из этих же цифр, расположенных в порядке возрастания, используя символьные переменные.

dsgsdfgasdasd dsgsdfgasdasd    2   20.04.2020 08:52    1

Ответы
линаким1 линаким1  13.10.2020 12:13

pascal

Объяснение:

var

 i, j ,k: integer;

 l, lnew: string;

 a: array of integer;

begin

 Write('Введите число >> ');

 ReadLn(l);

 SetLength(a ,length(l));

 for i := 0 to length(l) - 1 do

   a[i] := strtoint(l[i + 1]);    

 for i := 0 to length(l) - 2 do

     for j := i + 1 to length(l) - 1 do

       if a[i] > a[j] then

       begin

         k := a[i];

         a[i] := a[j];

         a[j] := k;

       end;

 

  for i := 0 to length(l) - 1 do

   lnew := lnew + inttostr(a[i]);

 WriteLn('Новое число равно ', lnew);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика