Составить программу в паскале: дан одномерный массив найдите разность наибольшего и наименьшего элемента этого массива

Софийка646436 Софийка646436    3   19.07.2019 13:00    5

Ответы
Rose123456789 Rose123456789  25.08.2020 10:47
Var 
a:array[1..10] of integer; 
max,min,i:integer;
Begin 
for i:= 1 to 10 do Begin   
write('Введите ',i,'-ый элемент массива ');   
Readln(a[i]);   
if i=1 then Begin     
min:=a[i];     
max:=a[i];   
End;   
if a[i]>max then max:=a[i];   
if a[i]<min then min:=a[i]; 
End; 
Write('Разность наибольшего и наименьшего равна ',max-min);
End.  
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика