Составить программу в паскале! 9 класс! ! ! без всяких div и mod. год является високосным, если его номер кратен 4. из кратных 100 високосными являются лишь те года, которые кратны также 400 (например, 1700, 1800 и 1900 — не високосные года, 2000 — високосный). дано натуральное число n. определить, является ли високосным год с таким номером.

aidnovna aidnovna    1   19.05.2019 17:10    2

Ответы
aalenka592 aalenka592  12.06.2020 21:25

programm p;

var n:integer;

begin

readln(n);

if n/4=int(n/4) then

begin

if (n/100=int(n/100))and(n/400<>int(n/400)) then

writeln('Не високосный') else

writeln('\Високосный';

end

else writeln('Не високосный')

 

end;

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика