Составить программу в паскаль, где при вводе любого трехзначного числа в результате все цифры этого числа записаны через запятую. например введите трехзначное число 123 результат 1,2,3

k1llerospace k1llerospace    3   16.09.2019 10:50    1

Ответы
aida2801 aida2801  07.10.2020 19:32
Program n1;
var a: integer;
begin
write('Введите трехзначное число: ');
readln(a);
write('результат: ',a div 100,',',a mod 100 div 10,',',a mod 10);
end.
ПОКАЗАТЬ ОТВЕТЫ
ooz ooz  07.10.2020 19:32
var
s:string;
begin
Write('Введите трехзначное число -> ');
readln(s);
Write('Результат -> ',s[1], ',');
write(s[2], ',');
Write(s[3]);
end.

Пример:

Введите трехзначное число -> 453
Результат -> 4,5,3
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика