tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу в паскаль.
Составить программу в паскаль. дана последовательность из 10 чисел (2,3,-15,4.4,0,-3.2,3,25,-5,0). найти произведение положительных элементов и количество отрицательных элементов.
feeedf
1 12.09.2019 20:40
3
Ответы
Koroleva12112002
07.10.2020 10:23
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=Arr(2.0,3.0,-15.0,4.4,0.0,-3.2,3.0,25.0,-5.0,0.0);
a.Println;
Writeln('Произведение положительных= ',
a.Where(t->t>0).Aggregate(1.0,(x,y)->x*y));
Writeln('Количество отрицательных= ',a.Where(t->t<0).Count)
end.
Результат
2 3 -15 4.4 0 -3.2 3 25 -5 0
Произведение положительных= 1980
Количество отрицательных= 3
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
LyusiaG
16.09.2021 08:43
Получить двоичный код с показанием решения ! 1)01082)80103)92414)14295)2007на решающую оценку!...
tyoma2223333
16.09.2021 08:41
От чего зависит мощность блока питания...
anna18181818
16.09.2021 08:40
Для значений A = истина, B = ложь, C = истина выполните следующие операции:...
Alexandra0606
06.09.2020 23:53
11. Найдите сведения и подготовьте сообщение о кодирования а) азбука Морзе...
Milka20060711
03.12.2020 10:40
Вычислить сумму конечного ряда для N=30 (Напишите программу в Pascal ABC)...
lisakiss1
18.05.2019 03:10
Что получится в результате работы следующего алгоритма, если 1) a=2, b=5, 2) a=0, b=-2 алг пример цел a,b,c нач ввод a,b если a 0 то если b 0 то c: =a+b иначе c: =10 кв иначе если...
Babaev11
14.04.2019 18:01
Решить 2 . 80 .доступны движения; вверх,вниз,влево и вправо...
Ааллалалал44
17.04.2019 05:30
К данным родовым понятиям подберите видовые. Запишите термины. 1) Значимые части слова: 2) Типы речи:...
kovtunenkoone
17.04.2019 05:30
Прочитайте тексты; около каждого кратко обозначьте речевую ситуацию. Что общего у текстов? Книжная это речь или разговорная?...
Keyanplay1
17.04.2019 05:30
Перечитайте правило в рубрике «Возьмите на заметку!». Употребите данные предлоги с существительными в указанном падеже,...
Популярные вопросы
Основанием четырехугольной пирамиды sabcd с равными ребрами является прямоугольник...
3
Найдите значений выражений.х=9,у=11. 1)х+у 2)2х+3у. 3) (3х+2у)÷7....
1
Сочинение по по цитате булгакова правду говорить легко и приятно...
3
Линейное уравнение с двумя переменными и его график11u+2j+22=025r-4w-100=0 ...
3
Уже час бьюсь ничего не понимаю...
1
Речення зі словом сковородка...
3
При спалюванні 10 мл газуватого вуглеводню утворилося 448 мл вуглекислого газу...
2
Для гидросульфата калия(khso4) и соляной кислоты постройте графическую формулу...
2
Укажите номера предложений, в которых средством выразительности речи является...
3
На что надо умножить 5 чтобы получилось 0,5...
3
// Внимание! Если программа не работает, обновите версию!
begin
var a:=Arr(2.0,3.0,-15.0,4.4,0.0,-3.2,3.0,25.0,-5.0,0.0);
a.Println;
Writeln('Произведение положительных= ',
a.Where(t->t>0).Aggregate(1.0,(x,y)->x*y));
Writeln('Количество отрицательных= ',a.Where(t->t<0).Count)
end.
Результат
2 3 -15 4.4 0 -3.2 3 25 -5 0
Произведение положительных= 1980
Количество отрицательных= 3