Составить программу в pascalabc, которая запрашивает ввод буквы латинского алфавита, а потом для данной буквы напечатает справа стоящую букву на стандартной клавиатуре. при этом считается, что справа от буквы "p" стоит буква "a", от буквы "l" стоит буква "z", от буквы "m" стоит буква "q".

Fluttys Fluttys    2   10.07.2019 09:30    5

Ответы
сссссср222 сссссср222  13.08.2020 14:20
// PascalABC.NET 3.0, сборка 1073
const
  s='';
var
  c:char;
  p:integer;
begin
  repeat
    Write('Введите латинскую букву, иной символ завершит работу: ');
    Readln(c);
    p:=Pos(c,s);
    if p>0 then Writeln('Рядом буква "',s[p+1],'"')
  until p=0
end.

Тестовое решение:
Введите латинскую букву, иной символ завершит работу: y
Рядом буква "u"
Введите латинскую букву, иной символ завершит работу: H
Рядом буква "J"
Введите латинскую букву, иной символ завершит работу: m
Рядом буква "q"
Введите латинскую букву, иной символ завершит работу: P
Рядом буква "A"
Введите латинскую букву, иной символ завершит работу: 5
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика