Составить программу (в pascal) позволяющую найти минимальный элемент массива. подсчитать количество элементов в массиве, равных минимальному. размеренность массива произвольная.

смурфик15 смурфик15    2   28.05.2019 17:30    5

Ответы
пвмыиыо пвмыиыо  26.06.2020 11:00
Program my;
var  k,i,z:integer; 
     a:array[1...N]:integer; 
begin
k:=99999;
for i:=1 to N do                   
 if a[i]<k then k:=a[i];
z:=0;
for i:=1 to N do 
 if a[i]=k then z:=z+1;
end.
=)  
ПОКАЗАТЬ ОТВЕТЫ
ЖаннаLife ЖаннаLife  26.06.2020 11:00
Uses crt;
const N=10;
var a:array [1..N] of integer;
     x,min,k:integer;
begin
for x:=1 to N do
begin
write('a[',x,']:',a[x]);
readln(a[x]);
end;
min:=a[1];
for x:=1 to N do
if a[x]<min then min:=a[x];
for x:=1 to N do
if a[x]=min then inc(k);
writeln('Минимальный элемент: ',min,'. Таких элементов в массиве: ',k);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика