Составить программу в pascal: найти все трехзначные числа, следующими свойствами: - сумма цифр числа а делится на 4; - сумма цифр числа а+2 также делится на 4

polinasmi1 polinasmi1    3   30.08.2019 18:40    1

Ответы
deniskakuzovle deniskakuzovle  06.10.2020 05:29
var i1,i2,s1,s2:integer;
begin
for i1:=100 to 997 do
begin
s1:=(i1 div 100)+(i1 div 10 mod 10)+(i1 mod 10);
i2:=i1+2;
s2:=(i2 div 100)+(i2 div 10 mod 10)+(i2 mod 10);
if (s1 mod 4=0)and(s2 mod 4=0) then writeln(i1,' ',i2);
end;
end.

Результат:
299 301
398 400
699 701
798 800
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика