Составить программу в pascal, найти сумму произведений 1 и 2, 3 и 4, и тд элементов массива состоящего из 10 значений. заранее !

Mahb Mahb    1   15.09.2019 19:10    2

Ответы
красава005 красава005  07.10.2020 18:04
Var
a:array[1..10] of integer;
i, ans:integer;
begin
  Writeln('Введите массив из 10ти элементов: ');
  for i:= 1 to 10 do
    read(a[i]);
  i:= 1; ans:= 0;
  while i < 10 do
    begin
      ans:= ans + a[i] * a[i+1];
      i:= i + 2;
    end;
  Writeln(ans);  
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика