tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу в pascal
Составить программу в pascal для нахождения корней квадратного уравнения ax^2+bx+c=0
3 28.05.2019 12:30
2
Ответы
anna0513wolf
01.10.2020 13:27
Uses crt;
var
d, a, b, c, x1, x2: real;
begin
writeln('Введите a, b, c');
readln(a, b, c);
d := b * b - 4 * a * c;
if d > 0 then
begin
x1 := (-b + sqrt(d)) / (2 * a);
x2 := (-b - sqrt(d)) / (2 * a);
writeln('x1 = ', x1:2:2);
writeln('x2 = ', x2:2:2);
end
else if d = 0 then
begin
x1 := -b / (2 * a);
writeln('x = ', x1:2:2);
end
else
writeln('Нет действительных корней');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
abdullaevs04
06.06.2019 20:10
Составь действия алгоритма по порядку и запиши его в трех формах: 1.посолила картофель. 2.бросила картофель в кипяток. 3.зажгла газовую плиту. 4.очистила картофель. 5.купила...
ssdjpiffi
06.06.2019 20:20
Двоичная система счисления. вычислите: а) 100010-101, б) 101000101: 101, в)101010: 110, г) 110111: 1011...
mashamaxi
06.06.2019 20:20
Двоичная система счисления. вычислите: а) 10101*10111, б)100010*101101, в) 1010001*1001...
1АндрейKEK
06.06.2019 20:20
1. от разведчика была получена следующая шифрованная радиограмма, переданная с использованием азбуки морзе: – ∙ ∙ ∙ – – – ∙ при передаче радиограммы было потеряно разбиение...
нуралик
06.06.2019 20:20
Много перевести из четвертой системы счисления во вторую числа 13 и 23 много...
vladdobryj071
06.06.2019 20:30
Сэлектронных таблиц смоделировать поведение следующей системы. рассматривается популяция простейших организмов, генетический код которых имеет информационную емкость 6...
SkeetNZ
30.03.2021 14:19
Дано список a = [1, 1, 2, 3, 5, 8, 13, 21, 34, 55, 89]. Виведіть всі елементи, які менше 15. Вивести всі парні числа із заданого списку...
NoAl3
30.03.2021 14:17
8_Тест «Общие сведение о языке программирования Паскаль» Вариант 1 1. Какие из следующих последовательностей символов можно считать операторами присваивания? б) a+3:=5...
20Fox06
30.03.2021 14:15
Решение с дано и формулами ! Задание 1. Цветное (с палитрой из 256 цветов) растровое графическое изображение имеет размер 10x10 точек. Какой объем памяти займет это изображение?...
Котошкольник1
30.03.2021 14:15
Практична по информатике 9 класс Обчислення в електронних таблицях Только 1,2,4)) ...
Популярные вопросы
Дано А (-1;-3;2),B (5;-1;-1),C (3;0;2) а)найдите координаты векторов...
3
разобраться с геометрией. Дано: треугольник BMK, угол B=90 градусов...
1
О чём делится Есенин со своей сестрой Шурой в стихотворениях посвященных...
3
Перепишите текст. Вставьте пропущенные буквы и знаки препинания. В каждом...
1
ВА=18см А=60 найти Вс...
2
У выражение: (1,5x-3-1,8y)*(-3); 2,3y-1,7(0,2y-4)+0,3(4-2y);-2,1(a-2b+3)-5(2a-b)...
2
Обозначь порядок действий в левой части. Реши уравнения. 390+4900÷k=460...
3
10 предложений больше описывать места...
1
Реши неравенство и запиши ответ в виде числового интервала: 6x−7 41−2x....
3
Важно ли было причиной смутного времени, введение самодержавия...
2
var
d, a, b, c, x1, x2: real;
begin
writeln('Введите a, b, c');
readln(a, b, c);
d := b * b - 4 * a * c;
if d > 0 then
begin
x1 := (-b + sqrt(d)) / (2 * a);
x2 := (-b - sqrt(d)) / (2 * a);
writeln('x1 = ', x1:2:2);
writeln('x2 = ', x2:2:2);
end
else if d = 0 then
begin
x1 := -b / (2 * a);
writeln('x = ', x1:2:2);
end
else
writeln('Нет действительных корней');
end.