Составить программу! : )в массиве из 10 целых чисел заменить все отрицательные элементы на минимальный элемент, а все положительные – на максимальный.

jru77 jru77    1   16.06.2019 19:40    4

Ответы
1298school 1298school  13.07.2020 16:51
На паскаль: 
var
a: array [1..10] of integer;

max, min, i: integer;

begin

for i := 1 to 10 do
read(a[i]);

 max:=-maxint;
 min:= maxint;
for i:= 1 to 10 do 
if  (a[i]>max) then max:=a[i];
for i := 1 to 10 do
if (a[i]<min) then min := a[i];
for i := 1 to 10 do
if (a[i]<0) then a[i] := min else if (a[i]>0) then a[i]:=max;
for i := 1 to 10 do
write(a[i],' ');
readln;
readln;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика