Составить программу в дано а(n,m). найти номер строки, где находится первый элемент, кратный 5. поменять местами последнюю и найденную строку.

Маша923892 Маша923892    1   03.09.2019 00:20    3

Ответы
nikitaursu11 nikitaursu11  06.10.2020 13:30
// PascalABC.NET 3.2, сборка 1483 от 14.06.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Write('Количество строк и столбцов в массиве:');
  var (n,m):=ReadInteger2;
  Writeln('*** Исходный массив [',n,',',m,'] ***');
  var a:=MatrRandom(n,m,-99,99);
  a.Println(4); Writeln(4*a.ColCount*'-');
  var t:=a.ElementsWithIndexes.Where(x->x[0] mod 5=0).Take(1);
  a.SwapRows((t.First)[1],n-1);
  Writeln('*** Результирующий массив ***'); a.Println(4)
end.

Пример
Количество строк и столбцов в массиве:4 5
*** Исходный массив [4,5] ***
 -32 -12  94 -28 -42
 -15  29  80  28 -69
  -5  68  63 -12  22
  59  84  65  14 -86

*** Результирующий массив ***
 -32 -12  94 -28 -42
  59  84  65  14 -86
  -5  68  63 -12  22
 -15  29  80  28 -69
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика