Составить программу в c++ дополнительного задания 2 . Фотка прикреплена заранее.


Составить программу в c++ дополнительного задания 2 . Фотка прикреплена заранее.

UAola UAola    1   07.11.2020 20:36    4

Ответы
juliina902 juliina902  07.12.2020 20:37

#include <iostream>

using namespace std;

double y(double a, double b, double c, double x) {

   if (c == x && b + c + x != 0)

       return ((a + b) * (a + c) * (a + x)) / (b + c + x);

   if (c != x && 1 + b != 0 && 1 + a != 0 && a / (1 + b) + b / (1 + a) >= 0)

       return sqrt(a / (1 + b) + b / (1 + a));

   return -1e9 - 7;

}

signed main() {

   double a, b, c, x, ans;

   cin >> a >> b >> c >> x;

   ans = y(a, b, c, x);

   ans == -1e9 - 7 ? cout << "No solution" : cout << ans;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика