Составить программу умножающую две обыкновенные дроби. как в pascal

biv12448 biv12448    3   06.09.2019 22:30    4

Ответы
Nichisniuk2017 Nichisniuk2017  06.10.2020 21:57
// PascalABC.NET 3.3, сборка 1542 от 05.10.2017
// Внимание! Если программа не работает, обновите версию!

uses NumLibABC;

begin
   var (num,denom):=ReadInteger2('Числитель и знаменатель 1-й дроби:');
   var f1:=Frc(num,denom);
   (num,denom):=ReadInteger2('Числитель и знаменатель 2-й дроби:');
   var f2:=Frc(num,denom);
   f1.Print; Write('* '); f2.Print; Write('= '); (f1*f2).Print
end.

Примеры
Числитель и знаменатель 1-й дроби: 4 9
Числитель и знаменатель 2-й дроби: 3 8
4/9 * 3/8 = 1/6

Числитель и знаменатель 1-й дроби: 32432424 10213133
Числитель и знаменатель 2-й дроби: 23123 12313123
32432424/10213133 * 23123/12313123 = 749934940152/125755562844359

Числитель и знаменатель 1-й дроби: 15 2
Числитель и знаменатель 2-й дроби: 8 15
15/2 * 8/15 = 4
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика